1. 25 Oct, 2019 1 commit
  2. 24 Oct, 2019 1 commit
  3. 22 Jun, 2019 1 commit
  4. 13 Jun, 2019 1 commit
  5. 29 May, 2019 2 commits
  6. 17 Apr, 2019 1 commit
  7. 16 Apr, 2019 1 commit
  8. 15 Apr, 2019 1 commit
  9. 11 Apr, 2019 2 commits
  10. 31 Mar, 2019 1 commit
  11. 25 Mar, 2019 2 commits
    • Michael Moll's avatar
      remove Debian 8 support · 457bcfb2
      Michael Moll authored
      457bcfb2
    • Scott Cabrinha's avatar
      Add Amazon 2018 to osreleasemajor for agent_restart_command · 716c556a
      Scott Cabrinha authored
      Amazon Linux now has a 2018 release date on their AMIs:
      
      ```
      # cat /etc/issue
      
      Amazon Linux AMI release 2018.03
      Kernel \r on an \m
      
      # facter -p os
      {
        architecture => "x86_64",
        family => "RedHat",
        hardware => "x86_64",
        name => "Amazon",
        release => {
          full => "2018.03",
          major => "2018",
          minor => "03"
        },
        selinux => {
          enabled => false
        }
      }
      ```
      
      So, when not specifying $agent_restart_command, we get this:
      
      ```
      Error: /Stage[main]/Puppet::Agent::Service::Systemd/Service[puppet-run.timer]: Provider systemd is not functional on this host
      ```
      716c556a
  12. 19 Mar, 2019 1 commit
  13. 11 Mar, 2019 1 commit
    • Ewoud Kohl van Wijngaarden's avatar
      Handle the pluginsync setting deprecation · 5ecda93a
      Ewoud Kohl van Wijngaarden authored
      In Puppet 4 the pluginsync setting was deprecated. At least in Puppet 5
      it generates a deprecation warning and in Puppet 6 it was removed.
      Because the default was already true, we only emit it if it's
      non-default to avoid the deprecation warning. In Puppet 6 we can detect
      an invalid setting so we hard fail.
      5ecda93a
  14. 03 Mar, 2019 1 commit
    • Ewoud Kohl van Wijngaarden's avatar
      Fixes #26199 - Fix dependency cycle when using git_repo · 964f110c
      Ewoud Kohl van Wijngaarden authored
      Previously this resulted in a dependency cycle. The tests didn't compile
      so didn't catch it.
      
          dependency cycles found: (File[/opt/puppetlabs/puppet/cache] => Class[Puppet::Server::Install] => Class[Puppet::Server::Config] => File[/opt/puppetlabs/puppet] => File[/opt/puppetlabs/puppet/cache])
      
      a61e010e introduced this by managing
      $sharedir in puppet::server::config. $vardir was managed in
      puppet::server::install. Since sharedir is actually
      /opt/puppetlabs/puppet and vardir is the cache directory within that, it
      created a cycle.
      964f110c
  15. 26 Feb, 2019 1 commit
  16. 14 Feb, 2019 1 commit
    • Matthias Baur's avatar
      Implement $server_max_open_files · 27eb2074
      Matthias Baur authored
      This commit implements the $server_max_open_files parameter which allows
      the user to configure the max open file descriptor limit for Puppetserver.
      
      Fixes GH-670.
      27eb2074
  17. 13 Feb, 2019 1 commit
  18. 14 Jan, 2019 2 commits
  19. 11 Jan, 2019 3 commits
  20. 10 Jan, 2019 3 commits
  21. 03 Jan, 2019 1 commit
  22. 29 Dec, 2018 3 commits
  23. 28 Dec, 2018 2 commits
  24. 27 Dec, 2018 4 commits
  25. 26 Dec, 2018 2 commits